Søge funktion?

Tags:    php mysqli

User
HeidiG @ 01.08.17 14:48
Nogen der kan se hvad jeg har gjort forkert her?

Fold kodeboks ind/udKode 




8 svar postet i denne tråd vises herunder
3 indlæg har modtaget i alt 3 karma
Sorter efter stemmer Sorter efter dato
får du nogle fejl ??
hvor langt kommer du i scriptet ??
står der det i din sql som du forvendter ??

jeg har prøvet at formaterer det og rette syntax fejl manglende tuborg
syntax mæssigt korrekt, tested i netbeans

(utested)
Fold kodeboks ind/udKode 




Med Venlig Hilsen
Ronny Olsen
http://olsensweb.dk

hvorfor fetcher du 2 gange det sammen ??
prøv dette (utested)
Fold kodeboks ind/udKode 


hvis det ikke virker må vi lige have en test tabel (den du kalder Databasen)

Med Venlig Hilsen
Ronny Olsen
http://olsensweb.dk

substr($foo->Dhits, 0, 200)
skal være
substr($row->Dhits, 0, 200)

og

while ($row = mysqli_fetch_array($query)) {
skal rettes til
while ($row = mysqli_fetch_object($query)) {



Med Venlig Hilsen
Ronny Olsen
http://olsensweb.dk

Indlæg senest redigeret d. 02.08.2017 09:43 af Ronny Jørn Olsen
User
HeidiG @ 01.08.17 16:51
Med din kode, åbner siden g man kan skrive i feltet og trykke søg. Men der kommer ingen resultater frem...

Den skriver ikke nogen fejl af hvad jeg kan se (har slået Debug.php til)



prøv at lave nogle test udskrifter inde i coden, så vi kan se hvor langt du kommer
Fold kodeboks ind/udKode 


Med Venlig Hilsen
Ronny Olsen
http://olsensweb.dk

User
HeidiG @ 01.08.17 17:04
Jeg tror fejlen ligger et sted i denne del:
Fold kodeboks ind/udKode 


Jeg kan få den så langt som at skrive "Search results:" - men så kommer der bare ikke mere....jeg har forsøgt at omskrive koden fra mysql til mysqli - så det er meget muligt at jeg har noget forkert?

Update:
Jeg kan få koden til at virke (ser det ud til) hvis jeg sletter en del af det.
Jeg skal så have puttet det info ind igen.
Fra den gamle kode er det dette her som ikke fungere i den nye:
Fold kodeboks ind/udKode 




Indlæg senest redigeret d. 01.08.2017 17:10 af HeidiG
User
HeidiG @ 02.08.17 09:24
Så skriver den ud, men henter ikke værdierne fra databasen.

Debug giver:
Fold kodeboks ind/udKode 




User
HeidiG @ 02.08.17 09:45
Det hjalp - nu virker det :)





Indlæg senest redigeret d. 02.08.2017 10:25 af HeidiG
t